BitMEX API import not working

i newly added BitMEX on my account, is anyone using this exchange?
i made a deposit and just a trade but nothing seems to be imported on coinpanda via API

Hey there,

The BitMEX API returns data also for wallet operations that have not yet occurred (unrealized pnl, etc), so we had to make some changes 1-2 months ago so that we exclude/ignore all transactions happening on the same date as the sync and also any future dates. That means if you ran the sync today (Nov 18), only transactions settled on Nov 17 and prior will be imported. You will need to sync again tomorrow to import today’s transactions.

I don’t remember on top of my head why we had to do this, but I believe it was for a good reason and also necessary to avoid duplicate transactions and/or wrong data imported.

1 Like

Just waited few days, seems transactions still not imported :frowning:

What was the date of that last transaction and any other details you can provide so we can take a look?

Just few hours before I opened this topic

Are these transactions for futures? If so, make sure to enable the “import futures trade history” in the API screen page.

Screenshot from 2021-11-25 15-35-16

Was a margin trade, enabling this flag imported the trades, but deposit still not shown

i’ve also tried CSV upload for deposits, but it spins indefinitely on “Uploading…” (background ajax request returns error 500)

Just did a quick test with the Bitmex API and it seems to be working correctly. Is the deposit transaction showing in the CSV file? Is it possible to get a copy of the file so we can check?

Here you are, still failing. Gofile - Free file sharing and storage platform

Hey,

Just identified the issue to be that we don’t get wallet balance changes settled in USDT now. Currently, we only get the wallet history in BTC. It will be a quick fix next week!

1 Like